安装zabbix 3.4版本编译报错configure: error: Unable to use libevent (libevent check failed) 解决办法

来自:互联网
时间:2019-02-16
阅读:

由于本站服务器进行了调整,所有的运行环境都进行了重装,打算把zabbix安装起来,以便服务器啥情况都有通知可以收到。于是到官网下载当前最新版本zabbix 3.4来安装,还是和之前的依赖略有不同,譬如:GFU免费资源网

版本编译报错configure: error: Unable to use libevent (libevent check failed)GFU免费资源网

解决办法如下:GFU免费资源网

yum install libevent-devel  -y

问题解决。GFU免费资源网

说明:当前我用的编译参数如下GFU免费资源网

./configure --prefix=/usr/local/zabbix/ --enable-server  --with-mysql --with-net-snmp --with-libcurl --with-libxml2 --with-unixodbc

如服务器是新服务器,一般依赖不足。建议一起安装如下依赖,减少因为缺少依赖报错的可能性:GFU免费资源网

yum install unixODBC-devel mysql-devel net-snmp-devel libxml2-devel libcurl-devel libevent-devel
返回顶部
顶部